エントリー

R620 DVD交換

806.jpg

R620のDVD-ROMですが、手に入れた当初から壊れてて動作しなかったんです。

まあ、OSやアプリのインストール自体は、USBをブータブルディスクにしたりして、何とかなったんですが、やっぱり少し面倒って事で取り換えることにしました。

最初は、そこらへんに転がっているジャンクのノートPCのDVD-Rでもって思ってたんですが、9.5mmの薄型なんですよR620って。

 

現役ノートから外すわけにもいかないので、とりあえずオークションで1,000円で落札です。

ブルーレイも考えたんですがね、USBメモリーの高容量化やUSB-HDDがあるんで、とりあえずはDVD-Rにしました。

 

ビデオカードも追加したし、音源も追加したし。

大きい・重い・多少うるさい・起動に時間がかかるってのを気にしなければ、快適になりました。

R620その後

  • 2020/05/12 22:37

セットアップしてから、既に仕事で使っています。

 

やっぱりノートパソコンと違って、画面が大きいのはいいですね~おじさんには

デュアルディスプレイなんで、資料を開きながら仕事も出来ますし。

何より、ソフトを多重に起動した時に、重くならないのがいいです。

良くあるのが、仕事をしている時に、電話がかかってきて別の仕事のソース開いて調べている時に、電話で別のデータ開いて・・・・と、重いソフトを幾つも立ち上げなきゃいけない時なんか、重くならないんで。

 

CPUとメモリーが効いてる感じです。

ただ、Mouse without Borders入れたから、早くマウスを動かすと、マウスカーソルが何処か他のパソコンに飛んで行っちゃって、見失う事が多々・・・

これは慣れるしか無いんでしょうね。

あと、昔の8bitマイコン時代からプログラムに勤しんでいる、おっさんプログラマーとしては、最近のストロークが小さくて静かなキーボード&マウスはあまり好きじゃ無いんですよ。

ストロークがある程度あって、カチカチと押した時の感触があるものが好きなんです(五月蠅いんですけど、一人で仕事してるんで)

個人的な好みは、PC-9801やX68000ぐらいの時のキーボードが好きなんですが(マウスは使い物になりませんが)

コロナ落ち着いたら、キーボードとマウス探しに行こうっと。

やっと机が

R620にHiper-VでWin7 32Bitももう一度インストールして、あとは仕事用のアプリを色々インストール、動作確認をして何とか使えるようになりました。

これで、机の上を占拠していたノートパソコンの1つを移動できます。

もう一つは、持ち運び用なので、デュアルディスプレイの横に、サブディスプレイとして配置して、Mouse without Bordersで繋ぎます。
 
もう一つ、データ収集用の常時電源の入ったWindowsVistaのパソコンもあるのですが、これもMouse without Bordersで繋ぎ、ほぼマルチディスプレイのようにマウスとキーボードを移動できます。(コピペは出来ないですが)

これで、机の隅に鎮座していた、ディスクトップ用のキーボードも外せます。

ああ、すっきりしたーって思ってたんですが、そうなるとどうしてもファイルサーバー&WEBサーバーの3台のキーボードが邪魔になってきました。

基本的に使うことはまれなので、ブックスタンドに立ててあるのと、通常時はTeraTermで接続して作業するんで撤去しても問題は無いんですが、たまにGUIで作業することもあるんで、置いてあるんです。

Hiper-VのWin7 32Bitでリモートディスクトップを使うことになるのなら、このサーバーにリモートディスクトップで接続してやるって事で、ごにょごにょとサーバーにインストールして、無事繋ぐことが出来ました。

まあ、以前から出来るのは判ってたんですが、面倒なのでやってなかったんです。

これで、サーバー用のキーボード&マウスも撤去できました。

PC自体の台数は減っていないんですが、何とか机の上がすっきりしました。

Windows10の2回起動

やっと、Windows10の2回起動が解決しました。

Windows何回入れなおしたことか・・・・

BIOSいじったり、ビデオカード外したり、付けたり・・・

結局、サーバー特有の、CPU・メモリー関係のドライバーが悪さをしていたみたいです。

再インストール中にエラーになって、これらのドライバーが読み込まれず、デバイスに!がついた状態だと、素直に再起動しだしたんです。

多分なんですが、インストール時にドライバーを読み込む順番が悪いんでしょうか?(エラーで他の更新プログラムが読み込めない)

さて、!がついた状態で更新をしてみると、これらの!の付いたドライバーも読み込まれるんですが、インストール順が更新プログラムの後にインストールされます。

ドキドキしながら再起動

見事、1回起動しました、その後何回やっても無事1回起動。

よしよし、トラブルが順番に改善していきます。

さて、再インストールで消えちゃったアプリ、インストールしなきゃ。

AVIUTILエンコード速度改善

AVIUTILのエンコードが遅い件ですが、何とか改善しました。

前回、拡張編集がシングルスレッドだと思っていたんですが、間違いでした(タブン)

 

色々と設定やら試してみていたんですが、どうも世の中の情報と食い違うんですよ。

どうしても、CPUのクロックが1.2G~1.5Gの間から上がらない、定格クロックは2.6Gのはず。

CHNEBENCHIをかけて高負荷をかけると、3Gまで上がるんですがなんで???

電源管理で、CPUを100%にしても上がらない・・・・

AVIUTILの設定を色々いじってみたんですが、どうしても上がらない・・・

 

BIOSの設定を眺めてみると、DELL Turbo Boostの設定があったんで、設定して最大パフォーマンスにしてみました。

ターボブーストが効いた状態で起動するんですが(3.1G)、ファンの音がジェット機並みにうるさいです、市販のディスクトップでは味わえないくらいの音なんです、これが。

いくら速くても使えないので元に戻して、色々と試してみてたんですが、どうもDellのBIOSでCPU電源管理(パフォーマンス管理)をするのが問題のようです。

まあ、そこはサーバなんですよ、いろんなOSを想定してるので、安全性第一って事でしょうか(OSの電源管理を信用してないんだな)

さて、OSに任せるとWindowsの電源管理でCPUのパワーをコントロールできるようになります。

この設定で、とりあえずエンコードしてみると、30分で終わりました(約半分)

ついでに、CPUを100%のままでエンコードすると、24分。

それでも、CPUの使用率はMAXで60%(平均50%)なんですが、半分でエンコード出来るようになったんで、とりあえずは良しとしましょう。

まあ、結局何処かでシングルコアの性能に左右されるって事が分りました。

E5-2690v2が安くなってきたら、CPU変えてみようっと。

 

起動時の不具合2

治ったと思った、起動時の不具合ですが、再発しました。
イベントログを探っていると、CPUのVT-xが他で使われていて(Hiper-V)、エラーだよんって(英語なんでテキトーです)
ここに書いてある呪文を実行しろって書いてあるんで、とりあえずやってみました。
そしたら、本体液晶に出てたCPUエラーが嘘のように消えた。
よし、っと思ったのもつかの間、また再現。
ほんの少しだけ、症状が出る時間が遅くなってるんだけど、逆に起動に時間がかかって困るぅ~
もうちょっと探らないと、たっ楽しい~

起動時の不具合?

R620ですが、どうも朝一に電源入れたときとか、再起動しているときとかに、なぜか、Windowsの起動中にリセットがかかる。

その後すんなり立ち上がってくれたりするのですがねぇ

Windows Updateの再起動の時にこれが起こると、目も当てられないことになる

いや、実際一回なった

電源入れるときや、リセットするときに、毎回「起動してね☆彡」と祈りながら立ち上がるのもあれなんで、原因を色々と探ってみました。

まずは、ドライバー系(特にビデオドライバー)を最新のものに入れ替えたりしたんだけど、効果なし。

R620君は、起動できないときは必ず、CPUエラーだぞ~って表示出すし

そうこうしているうちに、やっと原因が判明

高速スタートアップが原因でした。

細かいことはよくわからないのですが、OS終了時のデバイス状態と違うって事らしいです。

やっと安定して起動できる。

動画のエンコード

さて、Hiper-Vも設定できたし、もう一つやりたかった動画のエンコードでもしようかな(ワクワク)

現在使っている、AVIUTILを入れて、プラグインとコーディックを入れて、比較のために、前回作成した県オープンの動画をエンコードっと

ん?遅い

CPU使用率もMAXで25%しか出ていない。(しかもCPUクロックが低消費モードのままの1.2Gのままだし)

結局20分の動画のエンコードに1時間ちょいかかりました。

これじゃ、i5-U7200のノートパソコンよりちょっとだけしか速くなっていない

ちなみに、i7-4770Sでエンコードしてみたときは、30分ちょいで完了

AVIUTILが32bitアプリだからかと思い、Shotcut(x64)を入れて、フィルターで同じような事をしてみたんですが、こっちは12%程まで落ちて2時間近くかかる始末

って事は、AVIUTIL結構頑張ってるんだなぁ

 

デコードがボトルネックになっているのかと思い、L-SMASH関係を入れなおしてみたりしたんだけど、変わりなし。

.MTSファイルを素でそのままエンコードすると、CPUが85%まで上がること考えると、拡張編集(フィルター)が原因なんだな。

lua51関係(lua51jitも)色々と探ってみたり、パフォーマンス優先度を変えてみたりもしたんだけど、変わりなし。

どうやら、この拡張編集自体が重くて足を引っ張っているらしい、CPUクロック自体が高いi7-4770はこの処理が速いんで、結果エンコードが速かったんだなぁ

 

i7-4770S 3.1Ghz

i5-U7200 2.5Ghz

E5-2650v2 2.6Ghz

フィルター処理をシングルスレッドで処理してるとしたら、納得だわ~

何か他の方法考えないと

Hiper-V

Hiper-Vでラックマウントサーバにインストールした、Windows10Pro 64bitに、Windows7Pro 32bitをインストールしてみました。

実は、これがやりたかった、今仕事で使用しているのは、Windows10Home 64bitのノートパソコンなんで、横にWindows7Pro 32bitのノートパソコンを置いて、この仕事はこっちで、この仕事はこっちとかやってた。

同じIBMのパソコンなのに、キーアサインが違うから、操作ミスが多いんだよ。

特にショートカット多用するから、CtrlキーとFnキーが逆なのは致命的なんだよね。

一時はフルキー繋いでたりもしたんだけどね、 今はMicrosoftのMouse without Borders入れて、3台のパソコン間でマウスとキーボードをそのまま行き来出来るんだけど、フルキー繋ぐと、画面が遠くなっちゃうんだよ、おじさんにはつらいべ。

VMwareとかVirtualBoxも使ってみたんですが、動作はするけど仕事ではストレスが多そうなんで、やめちゃいました。

Windows7Pro時代にあった、XPモードってのが理想なんですが、どうなんでしょうか。

って訳で、例のラックマウントサーバをデュアルディスプレイにして(メインのG200eRは切れないので、実際にはトリプルモニターですが)、Windowsの中で切り替えれたらなんて思ってね。

たまたま、使わなくなったWindows7Pro 64bit とwindows7Pro 32bitが手元にあったんで、やってみました。

導入方法なんかは、説明サイトの方が詳しいので、そっちに任せて

ものすごくすんなり入りました。

ただね、画面の解像度が・・・・

ってしばらく四苦八苦してたら、リモートディスクトップで繋ぐといいって話なんで、やってみると

おお~

って感じで、何とか使えそうです

内臓G200eRビデオチップ

R620ラックマウントサーバに無事、Windows10Pro64Bitをインストール出来て、ビデオカードとHDDを追加して、少し五月蠅いけど快適な環境を作るとしていたんですが、どうも時々起動しない時がある、CPUのエラーが出ている。

色々調べていると、どうもWindowsアップデートで引っかかってるっぽい。

悪名高い、4月のアップデートが問題なようです。

(うちのゲーミングPCもこれにやられて、再インストールする羽目になっちゃいました)

とりあえず、不具合があるであろう更新プログラムを削除して、無事起動するようになりましたが、次のアップデートが怖いわぁ

さてもう一つ、このサーバーにはG200eRドライバが内蔵されているんですが、どうもWindows10では認識されないのらぁ

ネット上を探しても、同じ問題を抱えてる人が何人かいました。

まあ、映るんで問題は無いんですが、解像度とパフォーマンスが・・・・

署名のないドライバーを無理やり入れている人も居たんですが、色々と手探りしてみました。

DELLのサイトには、Windowsサーバ用のドライバはあるんですが、インストール途中に、未サポートのOSとかでインストールできない。

諦めて、R620のファームウエアをアップデートしようと、R620関連のファイルを色々とダウンロードしていると、ありましたぁ

古いバージョンのドライバが、自動インストールではなく、UnZipで解凍して手動でインストールするタイプ。

とりあえず、ダメ元でやってみたんですが、これが見事ビンゴ。

無事インストールできました・・・・がぁ

解像度って、サーバー向けの解像度しかサポートしていないのね

1600×1200とかって、そんなディスプレイ持ってないですぅ

結局パフォーマンスは改善されたんですが、解像度は以前と変わらずです。

HD画質にしたかったのにぃ~、まあビデオカード追加しているから問題は無いんですが。

 

R620は内臓GPUが無いと起動しないし

(R630からは追加したビデオカードでも起動できるらしい)

色々一筋縄ではいかない・・・・たっ・楽しいぃ~

ユーティリティ

新着エントリー

ううっ、頭の中がぁ
2020/07/11 16:13
だあああぁぁ
2020/07/09 16:32
もう一つ忘れてた
2020/07/08 08:58
うまくいった
2020/07/04 16:20
やっちまった
2020/07/03 23:21

新着コメント

Re:2017ふれまにっ杯募集
2017/01/30 from tatsuru3284
Re:ついに
2016/03/18 from redinpules.stt.TV
Re:ついに
2016/03/17 from Tatsuru
Re:ついに
2016/03/17 from redinpules.stt.TV
Re:県オープンの余韻
2016/02/18 from Tatsuru

過去ログ

Feed